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1 Introduction 
 
HorzVertControl.mvba is a MicroStation visual basic application created to place the horizontal and 
vertical control points in a table format and an alignment description using report files that were 
previously created. All elements are drawn using the correct IDOT symbologies and level 
assignments. The tables will be placed on the “RD_Pr_Roadway_Dimensions” level and the text on 
the “RD_Pr_Roadway_Notes” level. If these levels are not found the table and text will be placed on 
the “Default” level. Each Table is placed as a separate graphic group. 

 
1.1 District 2 HVC Control 

 
The District 2 HVC Control application is activated by use of the following key-in command: 
 

vba run [HorzVertControl]modStart.Start 
 
When the command is executed, the main dialog is displayed as shown below. 
 
 

 
 

Place HVC Tables 

Choose this check box to place a Horizontal Control Points, Survey Work Points, Bench Marks, Reference Tie 
Points, Apparent Property Corners or Chain Curves table. 
 
Place Chain Description 

Choose this check box to place the description of the selected chain. 

 
OK 

Pressing this button will display the dialog box of the selected HVC Control type. 

 

Refer to section 1.2 for placing HVC tables, section 1.4 for placing alignment descriptions, Appendix A 
for creating the input file for the horizontal control tables and Appendix B for creating the alignment 
descriptions. 
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1.2 Operation – Place HVC Tables 
 

The top portion of the dialog displays the various settings used for placing the “Horizontal and Vertical Control 
Tables”. 

 
 

 
 

 Click on the question mark to open a help file for this application. 
 
 

Survey Acsii File 

Click on the magnifying glass to browse to the “Survey Control Ascii” file that will be read to 
populate the tables. This file must be in a certain format for the application to read it properly. See 
“Appendix A” for the instructions on how to create the “Survey Control Ascii” file. 
 
Scale 

Select the scale that the tables will be placed at. 
 

The bottom portion of the dialog displays the points sorted by category. 
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Click in the desired “Control Table” tab to display the points for that category. 
 
Horizontal Control Points 

• All horizontal control points in the point number ranges of 1-99, 1000-1099 and 90000-
91000000. 

 
Survey Work Points 

• All survey work points in the point number ranges of 100-199 and 1100-1199. 
 
Bench Marks 

• All bench mark points in the point number ranges of 400-499 and 1400- 1499. 
 
Reference Tie Points 

• All reference tie points in the point number ranges of 500-699 and 1500-1699. 
 
Apparent Property Corners 

• All apparent property corner points in the point number ranges of 700-999 and 1700-1999. 

 

Select All 

              

Click on this button to select all the points in the active tab. 

Select None 

              

Click on this button to clear all the selected points in the active 
tab.  

 
 
Click on the “Place Table” button to draw the selected points in the proper HVC table format at a 
user defined data point in the design file. 
 
 
 

Note – The text placed in the various tables is annotative and will respond to annotation scale and 
should be placed using the annotation scale of “Full Size 1 =1”. 
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1.3 Examples of the HVC Tables 

 
Horizontal Control Points 
 

 
 
Survey Work Points 
 

 
 
Bench Marks 
 

 
 
Reference Tie Points 
 

 
 
Apparent Property Corners 
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1.4 Operation – Place Alignment Description 

 
The top portion of the dialog displays the various settings used for placing the “Alignment Description Text”. 

 
 

  
 

 Click on the question mark to open a help file for this application. 
 

 
Scale 

Select the scale that the alignment description text will be placed at. 
 

Survey Acsii File 

Click on the magnifying glass to browse to the “Alignment Description Ascii” file that will be read to 
[lace the text. This file must be in a certain format for the application to read it properly. See 
“Appendix B” for the instructions on how to create the “Alignment Description Ascii” file. 

 
Click on the “Place Alignment Text” button to draw the alignment description text at a user defined 
data point in the design file.    

Note – The text placed in the alignment description is annotative and will respond to annotation scale 
and should be placed using the annotation scale of “Full Size 1 =1”. 
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1.5 Example of Alignment Descriptions 
 

 
 
 
 
 

 
 



Horizontal and Vertical Control 
 

        
 7                                                                             3/18/2026 

HARD COPIES UNCONTROLLED 

IDOT - Region 2, District 2 

 
 
 
 
 
 

Note – The “Horizontal and Vertical Control Tables” dialog and the “Alignment Description Text” dialog 
will reappear after each table or chain description is placed in the design file. 
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Appendix A 
 

1. The following outlines the steps for creating the input file for the horizontal control tables and the placement 
in a table format. 

 
1)  Open the D2_*****-sht-ATB.dgn file, where ***** is the contract number of your project. 

 
2) Attach the *****Control.dgn as a reference, where ***** is the contract number of your project. 

 
• Open the “References” dialog by going to the “Drawing” workflow, “Home” tab, “Primary” 

group, “Attach Tools”, “Reference”. 
 

 
 

Note - The *****Control.dgn can be found in the “Surveys” folder in ProjectWise. 

 
 

3) Click on “Fit View” to see the entire control drawing or key-in “fit view extended”. 
 

 
 
 
4) Turn all the levels on and turn the following levels off if they are used. 

 
• Ge_Ex_Baseline 
• Ge_Ex_Baseline_Small_Tic 
• Ge_Ex_Baseline_Small_Tic_Sta 
• Ge_Ex_Centerline 
• Ge_Ex_Centerline_Small_Tic 
• Ge_Ex_Centerline_Small_Tic_Sta 
• Ge_Ex_Notation 
• Topo_Ex_Roadway_Notes 
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• The “Level Display” dialog can be accessed by going to the “Drawing” workflow, “Home” tab, 
“Primary” group, “Level Display”. 

 

 
 

 

   
 

Basically, you just need to display all the control points and turn off any unnecessary elements, 
text, and raster images. 

 
5) Select all the elements that are displayed by going to the “Drawing” workflow, “Home” tab, 

“Selection” group, “Element Selection”. 
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6) Turn all the alignment (“GE_*”) levels back on. The alignment will be used to calculate the station 
and offset of the horizontal control points, survey work points, reference tie points, benchmarks, 
and apparent property corners. 
 

7) With the elements still selected, enter the following key-in to create a report file for the horizontal 
control tables’ 
 
geometry report stationoffsetelevationfeature 

 
 

• The first heads up prompt will ask for you to data point (left click) on the existing alignment. 
Move your cursor to be on the alignment and when it highlights data point (left click) to select it. 

 
 

 
 
 
 
• The second heads up prompt will ask for you to data point (left click) to accept the selected 

alignment. 
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• The report dialog will open to a default report named “Station Offset Elevation Feature Report”. 
 

 

 
 

 
 
• In the “Reports” folder click on the “D2_StationOffsetNorthingEastingElevationFeature_CSV.xsl” 

report. 
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8) With the “D2_StationOffsetNorthingEastingElevationFeature_CSV.xsl” report still open, in 
ProjectWise navigate to the “\District 2\ORD Projects\*****\Program Development\Studies & 
Plans\Design\CADD\CADsheets\” folder, where ***** is the contract number of your project.  

 

 
 

 
9) There will be two blank text files (*.asc) for use with the control reports and for the chain 

descriptions. If either of the *.asc files have a [Template] in the name, you will need to rename it 
before opening it. 

 
For example: 
 
• [Template]-Chain_Description.asc  12345-Chain_Description.asc 
• [Template]-Control_Report.asc   12345- Control_Report.asc 

 
10) Open the “*****- Control_Report.asc” file by double clicking on it or right click and select “Open”. 

Where ***** is the contract number of your project. 
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11) In the “D2_StationOffsetNorthingEastingElevationFeature_CSV.xsl” report, right click in the body of 
the report and select “Select All”. 
 

 
 
 

12) In the “D2_StationOffsetNorthingEastingElevationFeature_CSV.xsl” report, right click in the body of 
the report and select “Copy”. 
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13) In the “*****- Control_Report.asc” file go to “Edit > Paste” or right click and select paste or press       
“Ctrl + V” on your keyboard.  

 
 Using Notepad++                             Using Notepad 

 

            
 
 
 
14) Go to “File > Save” or press “Ctrl + S” on your keyboard.  
 

                             Using Notepad++                         Using Notepad 
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15) Close the “*****- Control_Report.asc” file and check it back into ProjectWise. 
 

16) The “D2_StationOffsetNorthingEastingElevationFeature_CSV.xml” report can be saved for archival 
proposes. To save this file go to “File > Save As > Report (*.xml). 
 

 
 
 
• The report can be saved to ProjectWise or elsewhere. To save the report outside of ProjectWise 

click on “Cancel” to open the Windows “Save As” dialog to navigated to a local drive folder or a 
network folder. 
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• Navigate to the desired folder location, fill in the file name field and click on “Save”. 

 

  
 

 
17) The “*****- Control_Report.asc” file is ready to be used with the “Place HVC Tables” application.  
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Appendix B 
 

1. The following outlines the steps for creating the alignment descriptions for placement on the HVC Sheets. 
 

1) Open the D2_*****-sht-ATB.dgn file, where ***** is the contract number of your project. 
 

2) Attach the *****Control.dgn as a reference, where ***** is the contract number of your project. 
 

• Open the “References” dialog by going to the “Drawing” workflow, “Home” tab, “Primary” 
group, “Attach Tools”, “Reference”. 

 
 

 
 
 
 

3) Click on “Fit View” to see the entire control drawing or key-in “fit view extended”. 
 

 
 

 
4) Enter the following key-in to create a report file for the alignment descriptions. 

 
geometry report stationoffsetelevationfeature 
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• The first heads up prompt will ask for you to data point (left click) on the existing alignment. 
Move your cursor to be on the alignment and when it highlights data point (left click) to select it. 

 

 
 

• The second heads up prompt will ask for you to reset (right click) to accept the selected 
alignment. 

 

 
 

• The third heads up prompt will ask for you to identify the “Start Station” for the report. Press 
“Alt” on your keyboard. This will lock the start station at the beginning of the alignment. Data 
point (left click) to accept. 
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• The fourth heads up prompt will ask for you to identify the “End Station” for the report. Press 
“Alt” on your keyboard. This will lock the end station at the end of the alignment. Data point 
(left click) to accept. 

 

   
 
 
 
• The fifth heads up prompt will ask for you to key-in an interval value. Key-in “0.000” if it is not 

already in the “Interval” field. Data point (left click) to accept. 
 

 
 
 
• The sixth heads up prompt will ask for you to “Include Event Points”. Select “All” in the drop 

down. Data point (left click) to accept. 
 

 
 
 
• The seventh heads up prompt will ask for you to select the profile that is associated with the 

selected profile. Select “Active Profile” in the drop down. Data point (left click) to accept. 
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• The report dialog will open to a default report named “Horizontal Alignment Review Report”. 
   

 
 

 
 
• In the “Reports” folder click on the “CogoAlignmentDescriptionASCII.xsl” report. 
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5) With the “CogoAlignmentDescriptionASCII.xsl” report still open, in ProjectWise navigate to the 
“\District 2\ORD Projects\*****\Program Development\Studies & Plans\Design\CADD\CADsheets\” 
folder, where ***** is the contract number of your project.  

 

 
 

6) There will be two blank text files (*.asc) in the “CADsheets” folder for use with the control reports 
and for the chain descriptions. If either of the *.asc files have a [Template] in the name, you will 
need to rename it before opening it. 

 
For example: 
 
• [Template]-Chain_Description.asc  12345-Chain_Description.asc 
• [Template]-Control_Report.asc   12345- Control_Report.asc 

 
7) Open the “*****- Chain_Description.asc” file by double clicking on it or right click and select 

“Open”. Where ***** is the contract number of your project. 
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8) In the “CogoAlignmentDescriptionASCII.xsl” report, right click in the body of the report and select 
“Select All”. 
 

 
 
 

9) In the “CogoAlignmentDescriptionASCII.xsl” report, right click in the body of the report and select 
“Copy”. 
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10) In the “*****- Chain_Description.asc” file go to “Edit > Paste” or right click and select paste or press       
“Ctrl + V” on your keyboard.  

 
 Using Notepad++                             Using Notepad 

 

            
 
 
 
11) Go to “File > Save” or press “Ctrl + S” on your keyboard.  
 

                                Using Notepad++                  Using Notepad 
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12) Close the “*****- Chain_Description.asc” file and check it back into ProjectWise. 
 
13) The “CogoAlignmentDescriptionASCII.xml” report can be saved for archival proposes. To save this 

file go to “File > Save As > Report (*.xml). 
 

 
 
 
• The report can be saved to ProjectWise or elsewhere. To save the report outside of ProjectWise 

click on “Cancel” to open the Windows “Save As” dialog to navigated to a local drive folder or a 
network folder. 
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• Navigate to the desired folder location, fill in the file name field and click on “Save”. 
 

 
 
 

14) The “*****- Chain_Description.asc” file is ready to be used with the “Place HVC Tables” 
application.  


